注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

无明

 
 
 

日志

 
 

CISOC交换机基本配置命令全集  

2011-09-18 22:51:27|  分类: cisoc |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

交换机命令总结

基本配置命令
Switch >enable       进入特权模式
Switch #config terminal         进入全局配置模式
Switch (config)#hostname        设置交换机的主机名
Switch(config)#enable password          进入特权模式的密码(明文形式保存)
Switch(config)#enable secret             加密密码(加密形式保存) (优先)
Switch(config)#ip default-gateway      配置交换机网关
Switch(config)#show mac-address-table            查看MAC地址
Switch(config)logging synchronous                     阻止控制台信息覆盖命令行上的输入
Switch(config)no ip domain-lookup                                      关闭DNS查找功能
Switch(config)exec-timeout 0 0                                                         阻止会话退出
 
使用Telnet远程式管理
Switch (config)#line vty 0 4    进入虚拟终端
Switch (config-line)# password     设置登录口令
Switch (config-line)# login    要求口令验证
 
控制台口令
switch(config)#line console 0    进入控制台口
switch(config-line)# password xx    
switch(config-line)# 设置登录口令login    允许登录
<!--[if !supportLineBreakNewLine]-->
<!--[endif]-->
Cisco发现协议(CDP
Switch(config)#show cdp                                   显示Cisco设备全局配置信息
Switch(config)#show cdp interface 端口            查看CDP配置下端口信息
Switch(config)#show cdp neighbors                   显示直连Cisco设备信息
 Switch(config)#show cdp neighbors detail       查看邻居详细信息
 
<!--[if !supportLineBreakNewLine]-->
<!--[endif]-->

恢复出厂配置
Switch(config)#erase startup-config
Switch(config)delete vlan.dat


配置接口标识     接口标识用于区分路由器的各个接口。
switch(config)#interface fastethernet 0/1       以0/1 接口为例
switch(config)# description this is a fast Ethernet port used to connecting the company’s intranet!  

 
 
 
 Vtp配置
switch(config)#vtp domain        设置vtp域名
switch(config)#vtp password       设置vtp密码
switch(config)#vtp mode server /client/transparent  设置vtp服务器模式
switch(config)#vtp version         设置vtp版本
switch(config)#vtp pruning         启用vtp修解
注:要想从vtp中减少一台交换机只需将该交换机vtp 域名更改
Vlan基本配置
  Switch#vlan database                                                进去vlan配置模式
  Switch(vlan)#vlan 号码 name 名称                         创建vlan及vlan名
  Switch(vlan)#vlan号码 mtu数值                             修改MTU大小
  Switch(vlan)#exit                                                      更新vlan数据并推出
  Switch#show vlan                                                     查看\验证
  Switch#copy running-config startup-config             保存配置
  叫NO 删除VLAN
 

VLAN 中添加 删除端口
   Switch#config terminal                                            进入全局配置
   Switch(config)#interface fastethernet0/1                 进入要分配的端口
   Switch(config-if)#Switchport mode access             定义二层端口
   Switch(config-if)#Switchport acces vlan 号            把端口分给一个vlan
Switch(config-if)#switchport mode trunk    设置为干线
Switch(config-if)#switchport trunk encapsulation dot1q    设置vlan 中继协议
Switch(config-if)#no switchport mode 或 ( switchport mode access)    禁用干线
Switch(config-if)#switchport trunk allowed vlan add 1,2  从Trunk中添加vlans
Switch(config-if)#switchport trunk allowed vlan remove 1,2 从Trunk中删除vlan
Switch(config-if)#switchport trunk pruning vlan remove 1,2 ;从Trunk中关闭局部修剪

 查看vlan信息 Switch#show vlan brief              所有vlan信息
 查看vlan信息 Switch#show vlan id     某个vlan信息
 
注:Switch#show int trunk 查看trunk协议
注:可以使用default interface interface-id               还原接口到默认配置状态
          
   Trunk
  开启(no)          ——将端口设置为永久中继模式
  关闭(off)         ——将端口设置为永久非中继模式, 并且将链路转变为非中继链路
  企望(desirable)——让端口主动试图将链路转换成中继链路
  自动(auto)       ——使该端口愿意将链路变成中继链路
  
   配置接口为动态协商模式
       Switch(config)#interface 接口号
       Switch(config)#switchport mode dynamic  desirable/auto
 
    
生成树stp
Switch(config)#spanning-tree vlan <vlan-list>    启用stp生成树(基于vlan)
Switch(config)#spanning-tree vlan <vlan-list> root primary    指定根交换机(基于vlan)
Switch(config)#spanning-tree vlan <vlan-list> root secondary    指定备用根交换机(基于vlan)
Switch(config)#spanning-tree vlan <vlan-list> priority <0-65535> 指定交换机优先级(基于vlan)
(4096的倍数,值越小,优先级越高.默认为32768)
Switch(config)#no spanning-tree vlan <vlan-list> priority    将交换机的优先级恢复默认值(基于vlan)
Switch(config-if)#spanning-tree vlan <vlan-list> cost <0-200000000> 指定端口成本(起用trunk的端口模式下)
Switch(config-if)#spanning-tree vlan <vlan-list> port-prioty <0-255> 指定交换机端口优先级(基于vlan)
Switch(config-if)#spanning-tree portfast    配置快速端口(连接终端设备的端口状态)如pc机
Switch(config)#spanning-tree uplinkfast    配置上行速端口
注:在配置上行速端口前要先将基于vlan上的网桥优先级,网桥成本恢复默认值。起用了该命令后在进行优先级更改,
注:vlan为可选参数,当没有该参数时将修改所有vlan网桥的优先级\及所有的vlan端口成本
Switch#show spanning-tree summery    检测vlan生成树配置
Switch#show spanning-tree vlan <vlan-id> detail    浏览详细生成树配置信息
Switch#show spanning-tree interface <int-id> detail    浏览详细生成树端口配置信息

以太网通道配置
switch(config)#interface range fasternet0/1 - 2    将fasternet0/1和0/2 口捆绑
switch(config-if)#channel-group 1 mode on    配置以太通道模式
switch(config-if)#port-channel load-balance {dst-mac | src-mac}在链路间实现负载均衡
switch#show etherchannel  1  summary    查看通道信息 
switch#show etherchannel  load-balance    查看通道信息 

交换机显示命令:
switch#show vtp status    查看vtp配置信息
switch#show running-config    查看当前配置信息
switch#show vlan    查看vlan配置信息
switch#show interface    查看端口信息
switch#show int f0/0    查看指定端口信息
switch#dir flash:    查看闪存
switch#show version    查看当前版本信息
switch#show cdp    cisco设备发现协议  (可以查看聆接设备)
switch#show cdp traffic    杳看接收和发送的cdp包统计信息
switch#show cdp neighbors    查看与该设备相邻的cisco设备
switch#show interface f0/1 switchport                                    查看有关switchport的配置
switch#show cdp neighbors                              查看与该设备相邻的cisco设备

静态mac绑定
Switch#config t
Switch(config)#mac-address-table static aaaa.bbbb.cccc vlan 1 int fa0/5
Switch(config)#do show mac address-table
  评论这张
 
阅读(220)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018